summaryrefslogtreecommitdiffstats
path: root/misc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-04 20:46:14 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-04 20:46:14 +0200
commit2a01ebba58913863a68f12848fedea27ef155ebc (patch)
treea5d23c7774c520bc6dc1ca4aeb11d58b030d5eb5 /misc/CMakeLists.txt
parentb5e537f10f4271b0fbc3db38bc8b774615408b4f (diff)
downloadfilelight-2a01ebba58913863a68f12848fedea27ef155ebc.tar.gz
filelight-2a01ebba58913863a68f12848fedea27ef155ebc.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'misc/CMakeLists.txt')
-rw-r--r--misc/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/misc/CMakeLists.txt b/misc/CMakeLists.txt
index 065943e..b61d753 100644
--- a/misc/CMakeLists.txt
+++ b/misc/CMakeLists.txt
@@ -5,12 +5,16 @@ tde_install_icons( )
##### other data ################################
-install( FILES filelight_part.desktop
+tde_create_translated_desktop(
+ SOURCE filelight_part.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)
-install( FILES filelight.desktop
+tde_create_translated_desktop(
+ SOURCE filelight.desktop
DESTINATION ${XDG_APPS_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
)
install( FILES filelightrc