summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2023-08-06 01:07:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2023-08-06 09:23:43 +0200
commit0984c8a873d7ed24259cf1ba600a3c989cdb3b08 (patch)
tree35c942467312c2e4ffd3d654917e9579503f3702 /src/Makefile.am
parentba09a974bad106c61008615fb86deffe26f32bd3 (diff)
downloadk9copy-0984c8a873d7ed24259cf1ba600a3c989cdb3b08.tar.gz
k9copy-0984c8a873d7ed24259cf1ba600a3c989cdb3b08.zip
Fix incorrect use of dvdread includes.
It seems that the library has been designed for use includes in the form "#include <dvdread/...>" while we used includes without the "dvdread/" prefix. This caused that instead of using the standard path detected from pkg-config, the expected path had to be added to to -I flag. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9f7c0362e26f62dc81769ab55a89e32c3c9a268d)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index efa34fc..5ed2714 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
# set the include path for X, qt and KDE
-INCLUDES = -I/usr/include/dvdread -I$(top_srcdir)/k9Mplayer \
+INCLUDES = -I$(top_srcdir)/k9Mplayer \
-I$(top_srcdir)/k9author -I$(top_srcdir)/k9decmpeg -I$(top_srcdir)/k9devices \
-I$(top_srcdir)/k9vamps -I$(top_srcdir)/libdvdnav -I$(top_srcdir)/libk9copy -I$(includedir) $(all_includes)