summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:41:29 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:41:29 +0200
commit80833d85844b784609e68dea15ccedea6d870f39 (patch)
treeb3f21a90ff51c8b0a39f31ddb99d97eaf0b78f62 /CMakeLists.txt
parentb359cbd29f9ec59b1f6d01271a4ea784014d9c14 (diff)
downloadkeep-80833d85844b784609e68dea15ccedea6d870f39.tar.gz
keep-80833d85844b784609e68dea15ccedea6d870f39.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e841fb..03c7a5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files