summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-04-19 16:41:06 +0200
committergregory guy <g-gregory@gmx.fr>2019-04-21 20:19:23 +0200
commit55ebab38f1bc2c061eb3673029fee13615635221 (patch)
treeb390ff21b5340f9634a4baee2c7ba2383ee84298 /src/CMakeLists.txt
parentd58173e77380a3b1ea7b036af4bb6ea8135e514d (diff)
downloadkima-55ebab38f1bc2c061eb3673029fee13615635221.tar.gz
kima-55ebab38f1bc2c061eb3673029fee13615635221.zip
conversion to the cmake building system
Signed-off-by: gregory guy <g-gregory@gmx.fr>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..fbecc95
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,42 @@
+add_subdirectory( cpufreqd )
+add_subdirectory( sources )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}/src/sources
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### libkima (kpart)
+
+tde_add_kpart( libkima AUTOMOC
+
+ SOURCES
+ prefs.ui
+ kima.cpp
+ flowlayout.cpp
+ sourcelistitem.cpp
+ LINK
+ cpufreqd-static
+ sources-static
+ tdeui-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES ${PROJECT_NAME}.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+)