summaryrefslogtreecommitdiffstats
path: root/kmymoney2/widgets/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-14 20:54:59 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-14 20:54:59 +0100
commitd536400b45d5ea05df97d42b81802ef801cb2eda (patch)
tree4f939a22e459774769af71a2802535247bc2387c /kmymoney2/widgets/Makefile.am
parent25166939bdb48ffd0ec0afd96d812d36905f4718 (diff)
downloadkmymoney-d536400b45d5ea05df97d42b81802ef801cb2eda.tar.gz
kmymoney-d536400b45d5ea05df97d42b81802ef801cb2eda.zip
Cleanup and fix headers installed for public API
+ Added installation of headers that are referenced, but were not installed. + Some headers were listed as inst_HEADERS and also as noinst_HEADERS. + Replaced paths to directories in source code used in "include <...>". + Common "tdeversion.h" is now used instead of local "kdecompat.h". + Including "config.h" has been moved from ".h" to ".cpp" files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kmymoney2/widgets/Makefile.am')
-rw-r--r--kmymoney2/widgets/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/kmymoney2/widgets/Makefile.am b/kmymoney2/widgets/Makefile.am
index 53b832d..225b662 100644
--- a/kmymoney2/widgets/Makefile.am
+++ b/kmymoney2/widgets/Makefile.am
@@ -23,18 +23,18 @@ EXTRA_DIST = kmymoney.widgets kmymoneygpgconfigdecl.ui kmymoneyonlinequoteconfig
# but the file is included in the tar-ball. See also the separate target
# $(top_builddir)/kmymoney/xxx.h further down and the BUILT_SOURCES target.
instdir=$(includedir)/kmymoney
-inst_HEADERS = kmymoneydateinput.h kmymoneyedit.h kmymoneytitlelabel.h kmymoneyaccountselector.h kmymoneycategory.h kmymoneyaccounttreebase.h kmymoneyaccounttree.h kmymoneycurrencyselector.h kguiutils.h kmymoneywizard.h kmymoneyaccounttreebudget.h kmymoneyaccounttreeforecast.h kmymoneyaccountcombo.h register.h registeritem.h transaction.h scheduledtransaction.h stdtransactiondownloaded.h stdtransactionmatched.h selectedtransaction.h transactionform.h transactioneditorcontainer.h kmymoneylineedit.h kmymoneychecklistitem.h kmymoneylistviewitem.h kmymoneyforecastlistviewitem.h kmymoneyselector.h kmymoneyaccountcompletion.h kmymoneycompletion.h kmymoneycombo.h kbudgetvalues.h kaccounttemplateselector.h \
+inst_HEADERS = kmymoneydateinput.h kmymoneyedit.h kmymoneytitlelabel.h kmymoneyaccountselector.h kmymoneycategory.h kmymoneyaccounttreebase.h kmymoneyaccounttree.h kmymoneycurrencyselector.h kguiutils.h kmymoneywizard.h kmymoneyaccounttreebudget.h kmymoneyaccounttreeforecast.h kmymoneyaccountcombo.h register.h registeritem.h transaction.h scheduledtransaction.h stdtransactiondownloaded.h stdtransactionmatched.h selectedtransaction.h transactionform.h transactioneditorcontainer.h kmymoneylineedit.h kmymoneychecklistitem.h kmymoneylistviewitem.h kmymoneyforecastlistviewitem.h kmymoneyselector.h kmymoneyaccountcompletion.h kmymoneycompletion.h kmymoneycombo.h kbudgetvalues.h kbudgetvaluesdecl.h kaccounttemplateselector.h \
transactionsortoption.h
# include the widgets that are only available to KMyMoney here
-noinst_HEADERS = kbudgetvalues.h tdelistviewsearchline.h kmymoneyaccounttree.h \
- kmymoneyaccounttreebudget.h kmymoneyaccounttreeforecast.h kmymoneybriefschedule.h kmymoneycalculator.h kmymoneycalendar.h \
- kmymoneycategory.h kmymoneydatetbl.h kmymoneygpgconfig.h kmymoneyonlinequoteconfig.h \
+noinst_HEADERS = tdelistviewsearchline.h \
+ kmymoneybriefschedule.h kmymoneycalculator.h kmymoneycalendar.h \
+ kmymoneydatetbl.h kmymoneygpgconfig.h kmymoneyonlinequoteconfig.h \
kmymoneypriceview.h kmymoneyscheduledcalendar.h kmymoneyscheduleddatetbl.h \
kmymoneywizard_p.h registersearchline.h
# make sure, automatically generated files exist
-BUILT_SOURCES = settings $(top_builddir)/kmymoney/transactionsortoption.h mocs dialogs transactionsortoption.cpp kbudgetvaluesdecl.h kaccounttemplateselectordecl.h libkmymoney.la kmmwidgets.cpp
+BUILT_SOURCES = settings $(top_builddir)/kmymoney/transactionsortoption.h mocs dialogs transactionsortoption.cpp $(top_builddir)/kmymoney/kbudgetvaluesdecl.h kaccounttemplateselectordecl.h libkmymoney.la kmmwidgets.cpp
CLEANFILES = kmmwidgets.cpp
@@ -50,6 +50,10 @@ $(top_builddir)/kmymoney/transactionsortoption.h: transactionsortoption.h
if test -h $@; then rm $@; fi
ln -s `pwd`/transactionsortoption.h $@
+$(top_builddir)/kmymoney/kbudgetvaluesdecl.h: kbudgetvaluesdecl.h
+ if test -h $@; then rm $@; fi
+ ln -s `pwd`/kbudgetvaluesdecl.h $@
+
PICS_DIR=kmymoney2/pics
libkmymoney_la_SOURCES = kmmwidgets.cpp ../kmymoneysettings.cpp kmymoneycompletion.cpp kmymoneyaccountcombo.cpp kmymoneyaccountcompletion.cpp kmymoneycurrencyselector.cpp kmymoneyaccountselector.cpp kmymoneydatetbl.cpp kmymoneycalculator.cpp kmymoneycategory.cpp kmymoneycombo.cpp kmymoneylineedit.cpp kmymoneyedit.cpp kmymoneydateinput.cpp kmymoneyaccounttree.cpp kmymoneytitlelabel.cpp kguiutils.cpp kmymoneyaccounttreebase.cpp kmymoneyaccounttreebudget.cpp kmymoneyaccounttreeforecast.cpp register.cpp registeritem.cpp transaction.cpp scheduledtransaction.cpp stdtransactiondownloaded.cpp stdtransactionmatched.cpp transactionform.cpp kmymoneychecklistitem.cpp kmymoneylistviewitem.cpp kmymoneyselector.cpp transactionsortoption.cpp kbudgetvalues.cpp kbudgetvaluesdecl.cpp kaccounttemplateselector.cpp kaccounttemplateselectordecl.cpp
@@ -88,6 +92,7 @@ endif
dist-hook:
-rm -rf $(distdir)/transactionsortoption.h
-rm -rf $(distdir)/transactionsortoption.cpp
+ -rm -rf $(distdir)/kbudgetvaluesdecl.h
-rm -rf $(distdir)/kmmwidgets.cpp
messages: rc.cpp