summaryrefslogtreecommitdiffstats
path: root/src/knemod/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/knemod/Makefile.am')
-rw-r--r--src/knemod/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/src/knemod/Makefile.am b/src/knemod/Makefile.am
deleted file mode 100644
index 5a80d88..0000000
--- a/src/knemod/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-## Makefile.am for knemo
-
-messages: rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/knemod.pot
-
-# this has all of the subdirectories that make will recurse into. if
-# there are none, comment this out
-SUBDIRS = pics backends
-
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-kde_module_LTLIBRARIES = kded_knemod.la
-
-# set the include path for X, qt and KDE
-INCLUDES = -I$(srcdir)/../common -I$(srcdir)/backends $(all_includes)
-
-# the library search path.
-kded_knemod_la_LDFLAGS = -module -avoid-version $(all_libraries)
-
-# the libraries to link against.
-kded_knemod_la_LIBADD = $(LIB_TDEIO) $(LIB_TDEUTILS) $(LIB_QT) $(LIB_TDECORE) $(LIB_TDEUI) -lDCOP -ltdeinit_kded backends/libknemo_backends.la
-
-# which sources should be compiled for knemo
-kded_knemod_la_SOURCES = knemodaemon.cpp knemodaemon.skel interface.cpp \
- interfaceicon.cpp interfacetray.cpp \
- interfacemonitor.cpp \
- interfacestatusdlg.ui interfacestatusdialog.cpp \
- interfacetooltip.cpp signalplotter.cpp \
- interfacestatistics.cpp interfacestatisticsdlg.ui \
- interfacestatisticsdialog.cpp
-
-# these are the headers for your project
-noinst_HEADERS = knemodaemon.h interface.h interfaceicon.h \
- interfacemonitor.h \
- interfacestatusdialog.h interfacetray.h \
- interfacetooltip.h signalplotter.h \
- interfacestatistics.h global.h \
- interfacestatisticsdialog.h
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-services_DATA = knemod.desktop
-servicesdir = $(kde_servicesdir)/kded
-
-mydata_DATA = eventsrc
-mydatadir = $(kde_datadir)/knemo