summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:07:38 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:11:32 +0900
commit8c1330e2950654ffa52216313018eb6841401e14 (patch)
tree8db1a0169463f17f09d1c8ce286c009eb535379a /CMakeLists.txt
parentf4f3cbbebd58e8f44df1d4dbc7d576ed0c891eac (diff)
downloadknetstats-8c1330e2950654ffa52216313018eb6841401e14.tar.gz
knetstats-8c1330e2950654ffa52216313018eb6841401e14.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f125c4..05bb201 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )