summaryrefslogtreecommitdiffstats
path: root/chalk/plugins/tools/selectiontools/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-01 23:12:56 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-02-01 23:12:56 -0600
commitece35c015c54312eb13f583cc247cdd9a4051b4d (patch)
tree2c0599b8705e881f2b53678f48e97ffe4f616d22 /chalk/plugins/tools/selectiontools/Makefile.am
parentc260bb1b22af487f2410c2c7f6c35db3fe1d57b9 (diff)
downloadkoffice-ece35c015c54312eb13f583cc247cdd9a4051b4d.tar.gz
koffice-ece35c015c54312eb13f583cc247cdd9a4051b4d.zip
Rename many classes and header files to avoid conflicts with KDE4
Diffstat (limited to 'chalk/plugins/tools/selectiontools/Makefile.am')
-rw-r--r--chalk/plugins/tools/selectiontools/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/chalk/plugins/tools/selectiontools/Makefile.am b/chalk/plugins/tools/selectiontools/Makefile.am
index 49d3f571..5bb87983 100644
--- a/chalk/plugins/tools/selectiontools/Makefile.am
+++ b/chalk/plugins/tools/selectiontools/Makefile.am
@@ -1,4 +1,4 @@
-kde_services_DATA = chalkselectiontools.desktop
+kde_services_DATA = chaltdeselectiontools.desktop
# all_includes must remain last!
INCLUDES = -I$(srcdir)/../../../sdk \
@@ -9,13 +9,13 @@ INCLUDES = -I$(srcdir)/../../../sdk \
$(KOFFICE_INCLUDES) \
$(all_includes)
-chalkselectiontools_la_SOURCES = kis_tool_move_selection.cc \
+chaltdeselectiontools_la_SOURCES = kis_tool_move_selection.cc \
kis_tool_select_brush.cc kis_tool_select_contiguous.cc kis_tool_select_elliptical.cc \
kis_tool_select_eraser.cc kis_tool_select_outline.cc kis_tool_select_polygonal.cc \
kis_tool_select_rectangular.cc selection_tools.cc
# Install this plugin in the KDE modules directory
-kde_module_LTLIBRARIES = chalkselectiontools.la
+kde_module_LTLIBRARIES = chaltdeselectiontools.la
noinst_HEADERS = \
selection_tools.h \
@@ -28,13 +28,13 @@ noinst_HEADERS = \
kis_tool_select_elliptical.h
-chalkselectiontools_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -ltdecore -ltdeui -lkjs -ltdefx -ltdeio -ltdeparts
-chalkselectiontools_la_LIBADD = ../../../libchalkcommon.la \
+chaltdeselectiontools_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) $(LIB_QT) -ltdecore -ltdeui -lkjs -ltdefx -ltdeio -ltdeparts
+chaltdeselectiontools_la_LIBADD = ../../../libchalkcommon.la \
../../../../chalk/chalkcolor/libchalkcolor.la \
../../../../chalk/core/libchalkimage.la \
../../../../chalk/ui/libchalkui.la
-chalkselectiontools_la_METASOURCES = AUTO
+chaltdeselectiontools_la_METASOURCES = AUTO
KDE_OPTIONS = nofinal