summaryrefslogtreecommitdiffstats
path: root/karbon/core/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /karbon/core/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'karbon/core/Makefile.am')
-rw-r--r--karbon/core/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/karbon/core/Makefile.am b/karbon/core/Makefile.am
new file mode 100644
index 00000000..aabebf80
--- /dev/null
+++ b/karbon/core/Makefile.am
@@ -0,0 +1,73 @@
+INCLUDES = $(KOFFICE_INCLUDES) $(KOPAINTER_INCLUDES) \
+ -I$(srcdir)/.. \
+ -I$(srcdir)/../render \
+ -I$(srcdir)/../visitors \
+ $(LIBFREETYPE_CFLAGS) $(LIBFONTCONFIG_CFLAGS) $(all_includes)
+
+noinst_LTLIBRARIES = libkarboncore.la
+
+noinst_HEADERS = \
+ vcolor.h \
+ vcomposite.h \
+ vcomposite_iface.h \
+ vdashpattern.h \
+ vdocument.h \
+ vfill.h \
+ vglobal.h \
+ vgradient.h \
+ vgroup.h \
+ vobject_iface.h \
+ vgroup_iface.h \
+ vimage.h \
+ vkarbonplugin.h \
+ vlayer.h \
+ vobject.h \
+ vpath.h \
+ vpattern.h \
+ vsegment.h \
+ vselection.h \
+ vstroke.h \
+ vvisitor.h \
+ vlayer_iface.h \
+ vtext.h \
+ vtext_iface.h \
+ vclipgroup.h \
+ vcursor.h
+
+libkarboncore_la_SOURCES = \
+ vcolor.cc \
+ vcomposite.cc \
+ vcomposite_iface.cc \
+ vcomposite_iface.skel \
+ vdashpattern.cc \
+ vdocument.cc \
+ vfill.cc \
+ vglobal.cc \
+ vgradient.cc \
+ vgroup.cc \
+ vobject_iface.cc \
+ vobject_iface.skel \
+ vgroup_iface.cc \
+ vgroup_iface.skel \
+ vimage.cc \
+ vkarbonplugin.cc \
+ vlayer.cc \
+ vobject.cc \
+ vpath.cc \
+ vpattern.cc \
+ vsegment.cc \
+ vselection.cc \
+ vstroke.cc \
+ vvisitor.cc \
+ vlayer_iface.cc \
+ vlayer_iface.skel \
+ vtext.cc \
+ vtext_iface.cc \
+ vtext_iface.skel \
+ vclipgroup.cc \
+ vcursor.cc
+
+libkarboncore_la_LIBADD = $(LIBFONTCONFIG_LIBS)
+
+libkarboncore_la_METASOURCES = \
+ AUTO