summaryrefslogtreecommitdiffstats
path: root/kivio/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 01:29:50 +0000
commit8362bf63dea22bbf6736609b0f49c152f975eb63 (patch)
tree0eea3928e39e50fae91d4e68b21b1e6cbae25604 /kivio/Makefile.am
downloadkoffice-8362bf63dea22bbf6736609b0f49c152f975eb63.tar.gz
koffice-8362bf63dea22bbf6736609b0f49c152f975eb63.zip
Added old abandoned KDE3 version of koffice
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/koffice@1077364 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kivio/Makefile.am')
-rw-r--r--kivio/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kivio/Makefile.am b/kivio/Makefile.am
new file mode 100644
index 00000000..af7595b8
--- /dev/null
+++ b/kivio/Makefile.am
@@ -0,0 +1,17 @@
+SUBDIRS = kiviopart plugins templates
+
+# Note: kivio-sml-i18n.cpp and kivio-extract-18n-desc.pl
+# are only needed for I18N, neither for building nor for run-time
+
+package-messages:
+ $(MAKE) -f admin/Makefile.common package-messages
+ $(MAKE) -C po merge
+
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` >> rc.cpp
+ perl -n kivio-extract-i18n-desc.pl `find . -name desc -o -name \*.sml` >> rc.cpp
+ $(EXTRACTRC) --tag-group=none --tag=name --context=Stencils `find . -name \*.shape` >> rc.cpp
+ $(XGETTEXT) `find . -name \*.cpp -not -name \*.moc.\*` kiviopart/kivio_aboutdata.h -o $(podir)/kivio.pot
+
+include $(top_srcdir)/admin/Doxyfile.am