summaryrefslogtreecommitdiffstats
path: root/karbon/plugins/whirlpinch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'karbon/plugins/whirlpinch/Makefile.am')
-rw-r--r--karbon/plugins/whirlpinch/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/karbon/plugins/whirlpinch/Makefile.am b/karbon/plugins/whirlpinch/Makefile.am
new file mode 100644
index 00000000..a0d53a7c
--- /dev/null
+++ b/karbon/plugins/whirlpinch/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = $(KOFFICE_INCLUDES) -I$(top_srcdir)/karbon -I$(top_srcdir)/karbon/core $(KOPAINTER_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = karbon_whirlpinchplugin.la
+
+karbon_whirlpinchplugin_la_SOURCES = whirlpinchplugin.cc
+karbon_whirlpinchplugin_la_LIBADD = $(LIB_KPARTS) $(LIB_KOPAINTER) \
+ ../../libkarboncommon.la
+
+
+karbon_whirlpinchplugin_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+partpluginsdir = $(kde_datadir)/karbon/kpartplugins
+partplugins_DATA = whirlpinchplugin.rc
+
+METASOURCES = AUTO
+