summaryrefslogtreecommitdiffstats
path: root/kexi/plugins/scripting/kexiapp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kexi/plugins/scripting/kexiapp/Makefile.am')
-rw-r--r--kexi/plugins/scripting/kexiapp/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/kexi/plugins/scripting/kexiapp/Makefile.am b/kexi/plugins/scripting/kexiapp/Makefile.am
new file mode 100644
index 00000000..a2702a26
--- /dev/null
+++ b/kexi/plugins/scripting/kexiapp/Makefile.am
@@ -0,0 +1,21 @@
+include $(top_srcdir)/kexi/Makefile.global
+
+INCLUDES = -I$(top_srcdir)/kexi $(KROSS_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = krosskexiapp.la
+
+krosskexiapp_la_SOURCES = \
+ kexiapppart.cpp \
+ kexiappmainwindow.cpp \
+ kexiappmodule.cpp
+
+krosskexiapp_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) $(VER_INFO) -module
+krosskexiapp_la_LIBADD = \
+ $(LIB_QT) \
+ $(LIB_KDECORE) \
+ $(LIB_KROSS_API) \
+ $(LIB_KROSS_MAIN) \
+ $(top_builddir)/kexi/core/libkexicore.la
+
+METASOURCES = AUTO
+SUBDIRS = .