summaryrefslogtreecommitdiffstats
path: root/lib/kotext/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kotext/tests/Makefile.am')
-rw-r--r--lib/kotext/tests/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/kotext/tests/Makefile.am b/lib/kotext/tests/Makefile.am
new file mode 100644
index 00000000..a505dce1
--- /dev/null
+++ b/lib/kotext/tests/Makefile.am
@@ -0,0 +1,24 @@
+INCLUDES = $(KOFFICECORE_INCLUDES) $(KOFFICEUI_INCLUDES) $(KOTEXT_INCLUDES) $(all_includes)
+KDE_CXXFLAGS = $(USE_EXCEPTIONS)
+
+METASOURCES = AUTO
+
+check_PROGRAMS = kotextformattertest kobordertest kovariabletest
+
+TESTS = kotextformattertest kovariabletest
+
+LDADD = ../libkotext.la
+AM_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+kobordertest_SOURCES = kobordertest.cpp
+kotextformattertest_SOURCES = kotextformattertest.cpp
+kovariabletest_SOURCES = kovariabletest.cpp
+
+check_LTLIBRARIES = kunittest_KoUserStyleTester.la
+
+kunittest_KoUserStyleTester_la_SOURCES = KoUserStyleTester.cpp
+kunittest_KoUserStyleTester_la_LIBADD = ../libkotext.la -lkunittest
+kunittest_KoUserStyleTester_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+
+check-local:
+ kunittestmodrunner