summaryrefslogtreecommitdiffstats
path: root/lib/kross/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/kross/python/Makefile.am')
-rw-r--r--lib/kross/python/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/lib/kross/python/Makefile.am b/lib/kross/python/Makefile.am
new file mode 100644
index 00000000..5eff2abe
--- /dev/null
+++ b/lib/kross/python/Makefile.am
@@ -0,0 +1,33 @@
+include $(top_srcdir)/lib/kross/Makefile.global
+
+kde_module_LTLIBRARIES = krosspython.la
+
+krosspython_la_LDFLAGS = $(KDE_PLUGIN) $(all_libraries) $(LIBPYTHON) $(PYTHONLIB) -module $(VER_INFO)
+
+noinst_HEADERS = \
+ pythonextension.h \
+ pythonmodule.h \
+ pythonobject.h \
+ pythonscript.h \
+ pythonsecurity.h \
+ pythoninterpreter.h \
+ pythonconfig.h
+
+krosspython_la_SOURCES = \
+ pythonextension.cpp \
+ pythonmodule.cpp \
+ pythonobject.cpp \
+ pythonscript.cpp \
+ pythonsecurity.cpp \
+ pythoninterpreter.cpp
+
+krosspython_la_LIBADD = \
+ $(LIB_QT) \
+ $(LIB_KDECORE) \
+ cxx/libkrosspythoncxx.la \
+ ../api/libkrossapi.la \
+ ../main/libkrossmain.la
+
+INCLUDES = $(KROSS_INCLUDES) $(PYTHONINC) $(all_includes)
+METASOURCES = AUTO
+SUBDIRS = cxx scripts .