summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:15:59 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:12:16 +0900
commitf4e3d22da4cf32733a269e51486b02860cd8d5b6 (patch)
treebe75db3dfa7e85556c4d3a360c950a82f6b8da19 /CMakeLists.txt
parent17d6fb351b50efc8747551b65ac74b9b2e84820a (diff)
downloadkompose-f4e3d22da4cf32733a269e51486b02860cd8d5b6.tar.gz
kompose-f4e3d22da4cf32733a269e51486b02860cd8d5b6.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d1eec0..0630e82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -35,11 +40,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )