summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /Makefile.am
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..e787d42
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,20 @@
+## kdepim/kpilot/Makefile.am
+## (C) 1997 Stephan Kulow
+## Modified by Adriaan de Groot
+
+SUBDIRS = lib kpilot conduits
+
+messages:
+ $(EXTRACTRC) `find . -name "*.rc" -o -name "*.ui"` > rc.cpp
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp"` -o $(podir)/kpilot.pot
+ -rm -f rc.cpp
+
+DOXYGEN_REFERENCES = kpilot/lib kpilot/kpilot
+include $(top_srcdir)/admin/Doxyfile.am
+
+# Just for the KPilot developers: grab all the strings, for checking.
+devel-pot :
+ extractrc `find . -name "*.rc" -o -name "*.ui"` > /tmp/rc.cpp
+ xgettext -C --keyword=i18n --keyword=I18N_NOOP -o /tmp/kpilot.po \
+ `find . -name "*.cc"` /tmp/rc.cpp
+