summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-01-14 13:48:58 +0100
committergregory guy <gregory-tde@laposte.net>2020-01-14 14:23:26 +0100
commite383a9d6aecec8ed53d1a0f3ce804f1ce550476f (patch)
tree5a11c98785f9537985f25c5f83f03d7f34fccb7c /CMakeLists.txt
parent862f549cc83f137a6eebba5c7af6d2d14cf6c098 (diff)
downloadksensors-e383a9d6aecec8ed53d1a0f3ce804f1ce550476f.tar.gz
ksensors-e383a9d6aecec8ed53d1a0f3ce804f1ce550476f.zip
Drop automake build support.
Add basic cmake build instructions. Delete LEEME, LIESMICH and LISEZMOI files. Delete empty file NEWS. Rework of the FAQ, INSTALL and README files. Add detection for the lm-sensors and math libc libraries. Move the ksensors.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Add French description and comments in the ksensors.desktop file. Some cosmetics here and there. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9f5be7..27d7140 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,7 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )