summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-22 12:21:45 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-22 12:22:04 +0200
commit285d41980cbdd206c7f8724ae510e622d2fd2a21 (patch)
tree52b67e594ab04feaebab7b2ffbd88b7f389b867e /CMakeLists.txt
parentc41fce1a11334718c0cde24652e0f00b19e10066 (diff)
downloadkshowmail-285d41980cbdd206c7f8724ae510e622d2fd2a21.tar.gz
kshowmail-285d41980cbdd206c7f8724ae510e622d2fd2a21.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9f1147122934ad21ab862468d4163b90be15c9fa)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a571228..337c402 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,8 +71,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( pics )
add_subdirectory( sounds )
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files