summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-30 11:03:15 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-10-01 17:16:10 +0900
commit6726e2fbb9c2cfc27bc67e7793863bc036b55944 (patch)
treecd98714f8509e774befe0def178a03ec1582ef85 /CMakeLists.txt
parent61254b9781405072cc10e9e3a57fa02460139a29 (diff)
downloadkshowmail-6726e2fbb9c2cfc27bc67e7793863bc036b55944.tar.gz
kshowmail-6726e2fbb9c2cfc27bc67e7793863bc036b55944.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder templates. Delete rpm stuff (kshowmail.spec and build-kshowmail folder). Rework of the README and AUTHORS files. Add BUGS file. Move the kshowmail.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 and bug 2408. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit e167d15409204539a0fa3a5b7260ca090192d6fa)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96eb9ea..a50c3f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -68,10 +68,10 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
-add_subdirectory( pics )
-add_subdirectory( sounds )
+add_subdirectory( pics )
+add_subdirectory( sounds )
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )