summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-22 12:21:45 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-22 12:22:04 +0200
commit285d41980cbdd206c7f8724ae510e622d2fd2a21 (patch)
tree52b67e594ab04feaebab7b2ffbd88b7f389b867e /doc/CMakeLists.txt
parentc41fce1a11334718c0cde24652e0f00b19e10066 (diff)
downloadkshowmail-285d41980cbdd206c7f8724ae510e622d2fd2a21.tar.gz
kshowmail-285d41980cbdd206c7f8724ae510e622d2fd2a21.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9f1147122934ad21ab862468d4163b90be15c9fa)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
deleted file mode 100644
index f6eec15..0000000
--- a/doc/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
-list( REMOVE_ITEM _dirs html man )
-
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _dir IN LISTS _dirs )
- if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}
- AND ( "${_dir}" STREQUAL "en" OR
- "${_linguas}" MATCHES "^;*$" OR
- ";${_linguas};" MATCHES ";${_dir};" ))
- file( GLOB _doc_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} ${_dir}/*.docbook )
- if( _doc_files )
- list( FIND _doc_files "index.docbook" _find_index )
- if( -1 EQUAL _find_index )
- set( _noindex "NOINDEX" )
- else()
- unset( _noindex )
- endif()
- tde_create_handbook(
- SOURCE_BASEDIR ${_dir}
- ${_noindex}
- LANG ${_dir}
- DESTINATION ${PROJECT_NAME}
- )
- endif()
- endif()
-endforeach()
-
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/html/CMakeLists.txt )
- add_subdirectory( html )
-endif()
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/man/CMakeLists.txt )
- add_subdirectory( man )
-endif()