summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-10-01 20:01:09 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-10-01 20:11:27 +0900
commit54a6036f059620e55df5e574ef8fbf3f3671a158 (patch)
tree47fc0d4f7cdd04b78e0871b25a80291c9fba740c /translations/messages/CMakeLists.txt
parente167d15409204539a0fa3a5b7260ca090192d6fa (diff)
downloadkshowmail-54a6036f059620e55df5e574ef8fbf3f3671a158.tar.gz
kshowmail-54a6036f059620e55df5e574ef8fbf3f3671a158.zip
Copy translation files to new translations folder.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )