summaryrefslogtreecommitdiffstats
path: root/extras/shutdown/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-10 03:24:07 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-10 03:24:07 +0200
commit33c97fa091a67fbfcaae19b388c56a931bfca72a (patch)
tree6d74d9f90f36bfa3cb4206e5d6ddfa44915785a1 /extras/shutdown/CMakeLists.txt
parenta3f22d8e5baa497d3d5d4c02bce0bce7fbf1e9a0 (diff)
downloadkshutdown-33c97fa091a67fbfcaae19b388c56a931bfca72a.tar.gz
kshutdown-33c97fa091a67fbfcaae19b388c56a931bfca72a.zip
Simplify CMake rules for desktop file translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'extras/shutdown/CMakeLists.txt')
-rw-r--r--extras/shutdown/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/extras/shutdown/CMakeLists.txt b/extras/shutdown/CMakeLists.txt
index 68be21c..e76cfe3 100644
--- a/extras/shutdown/CMakeLists.txt
+++ b/extras/shutdown/CMakeLists.txt
@@ -1,9 +1,7 @@
file( GLOB _files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} .directory *.desktop )
-foreach( _source ${_files} )
- tde_create_translated_desktop(
- SOURCE ${_source}
- DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras/shutdown
- PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/extras
- )
-endforeach()
+tde_create_translated_desktop(
+ SOURCE ${_files}
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/extras/shutdown
+ PO_DIR extras
+)