summaryrefslogtreecommitdiffstats
path: root/kshutdownlockout/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kshutdownlockout/CMakeLists.txt')
-rw-r--r--kshutdownlockout/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/kshutdownlockout/CMakeLists.txt b/kshutdownlockout/CMakeLists.txt
new file mode 100644
index 0000000..a98caee
--- /dev/null
+++ b/kshutdownlockout/CMakeLists.txt
@@ -0,0 +1,35 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kshutdownlockout_panelapplet (kpart)
+
+tde_add_kpart( kshutdownlockout_panelapplet AUTOMOC
+
+ SOURCES
+ lockout.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kshutdownlockout.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/applets
+)