summaryrefslogtreecommitdiffstats
path: root/src/themes/MoodinKDE/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/themes/MoodinKDE/CMakeLists.txt')
-rw-r--r--src/themes/MoodinKDE/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/themes/MoodinKDE/CMakeLists.txt b/src/themes/MoodinKDE/CMakeLists.txt
index d0fbb88..68afed2 100644
--- a/src/themes/MoodinKDE/CMakeLists.txt
+++ b/src/themes/MoodinKDE/CMakeLists.txt
@@ -1,4 +1,13 @@
+file( GLOB _pics RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.png *.jpg )
+
install(
- FILES Background.jpg Preview.png Theme.rc
+ FILES ${_pics}
DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/MoodinKDE
)
+
+tde_create_translated_desktop(
+ SOURCE Theme.rc
+ KEYWORDS Label1 Label2 Label3 Label4 Label5
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/MoodinKDE
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/themes
+)