summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-22 13:43:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-22 13:44:04 +0200
commit80d6193590cbf23586df2dca4903aa0bef8b87fa (patch)
tree52400214b7e540aa4e02bb8d1233b95dbdabcf47 /CMakeLists.txt
parent3389fcde7b3bfd027564cb0908959e2e8bbe580e (diff)
downloadkstreamripper-80d6193590cbf23586df2dca4903aa0bef8b87fa.tar.gz
kstreamripper-80d6193590cbf23586df2dca4903aa0bef8b87fa.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8ac87cbc104405b6dc3388829177c4db9f5da4ae)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38a0d1f..30271a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files