summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-14 14:45:40 +0100
committergregory guy <gregory-tde@laposte.net>2020-03-14 16:04:08 +0100
commit6d5cbbbea9dd0b8bafb91cdf13366b45da9c61d1 (patch)
treecba15b0042f1ad98af0c917e8f71affcd8f99fc0 /po/CMakeLists.txt
parent60e467f0f8473b9cf358284828722868b77d1045 (diff)
downloadkstreamripper-6d5cbbbea9dd0b8bafb91cdf13366b45da9c61d1.tar.gz
kstreamripper-6d5cbbbea9dd0b8bafb91cdf13366b45da9c61d1.zip
Conversion to the cmake building system.
Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..46fba83
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,6 @@
+# build translations if some are already available
+
+file( GLOB _srcs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+if( _srcs )
+ tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
+endif( )