summaryrefslogtreecommitdiffstats
path: root/plugins/rssfeed/rss/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
commit9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0 (patch)
treed088b5210e77d9fa91d954d8550e00e372b47378 /plugins/rssfeed/rss/Makefile.am
downloadktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.tar.gz
ktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.zip
Updated to final KDE3 ktorrent release (2.2.6)
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/ktorrent@1077377 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'plugins/rssfeed/rss/Makefile.am')
-rw-r--r--plugins/rssfeed/rss/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/rssfeed/rss/Makefile.am b/plugins/rssfeed/rss/Makefile.am
new file mode 100644
index 0000000..75b570a
--- /dev/null
+++ b/plugins/rssfeed/rss/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = \
+ -I$(top_srcdir)/src \
+ $(all_includes)
+
+noinst_LTLIBRARIES = \
+ librsslocal.la
+
+noinst_HEADERS = article.h document.h global.h image.h textinput.h \
+ loader.h librss.h
+
+librsslocal_la_SOURCES = article.cpp document.cpp image.cpp textinput.cpp \
+ tools_p.cpp loader.cpp
+
+librsslocal_la_METASOURCES = AUTO
+
+check_PROGRAMS = testlibrss
+testlibrss_SOURCES = testlibrss.cpp
+testlibrss_LDFLAGS = $(all_libraries)
+testlibrss_LDADD = librsslocal.la $(LIB_KIO)
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)