summaryrefslogtreecommitdiffstats
path: root/utests/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-01-20 02:37:40 +0000
commit9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0 (patch)
treed088b5210e77d9fa91d954d8550e00e372b47378 /utests/Makefile.am
downloadktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.tar.gz
ktorrent-9ad5c7b5e23b4940e7a3ea3ca3a6fb77e6a8fab0.zip
Updated to final KDE3 ktorrent release (2.2.6)
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/ktorrent@1077377 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'utests/Makefile.am')
-rw-r--r--utests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/utests/Makefile.am b/utests/Makefile.am
new file mode 100644
index 0000000..eb25f53
--- /dev/null
+++ b/utests/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(srcdir)/../libktorrent -I$(srcdir)/.. $(all_includes)
+METASOURCES = AUTO
+noinst_HEADERS = unittest.h testrunner.h upnpparsedescriptiontest.h \
+ upnpparseresponsetest.h dhtmsgparsetest.h biginttest.h rc4test.h difflehellmantest.h
+bin_PROGRAMS = ktutester
+ktutester_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+ktutester_SOURCES = unittest.cpp testrunner.cpp main.cpp \
+ upnpparsedescriptiontest.cpp upnpparseresponsetest.cpp dhtmsgparsetest.cpp biginttest.cpp \
+ rc4test.cpp difflehellmantest.cpp
+ktutester_LDADD = ../plugins/upnp/libktupnp.la \
+ ../libktorrent/libktorrent.la
+KDE_CXXFLAGS = $(USE_EXCEPTIONS) $(USE_RTTI)