summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-12-27 11:51:10 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-12-27 18:20:39 +0900
commita6a56789c93c3d235bbd188bb744d20301538f8e (patch)
treee33df6c47c220139446061a392d53933d1fdd2b3 /CMakeLists.txt
parent8e0ae7e04dd8ac827556c475be344aeba045ea87 (diff)
downloadlibr-a6a56789c93c3d235bbd188bb744d20301538f8e.tar.gz
libr-a6a56789c93c3d235bbd188bb744d20301538f8e.zip
Replace pthread and dl linking with cmake-based variablesHEADmaster
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e6692f..743cb65 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ set( PACKAGE_VERSION 0.7.0 )
##### include essential cmake modules ###########
include( FindPkgConfig )
+include( FindThreads )
include( CheckIncludeFile )
include( CheckFunctionExists )
include( CheckLibraryExists )
@@ -106,17 +107,6 @@ if( WITH_GTK )
endif( )
endif( WITH_GTK )
-set( DL_LIBRARIES dl )
-check_library_exists( ${DL_LIBRARIES} dlopen /lib HAVE_LIBDL )
-if( NOT HAVE_LIBDL )
- unset( DL_LIBRARIES )
- check_function_exists( dlopen HAVE_DLOPEN )
- if( HAVE_DLOPEN )
- set( HAVE_LIBDL 1 )
- endif( HAVE_DLOPEN )
-endif( NOT HAVE_LIBDL )
-
-set( EXTRA_LIBRARIES "-lm -lpthread" )
if( UNIX )
set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden" )
endif( UNIX )