summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKyle Russell <bkylerussell@gmail.com>2016-09-07 14:49:48 -0400
committerKyle Russell <bkylerussell@gmail.com>2016-09-21 23:04:05 -0400
commit21fd4d27bb248d506b37c3c43969f3db2f67c820 (patch)
tree5874a7b0662530eb820d642d096f45844a878c45 /configure.ac
parent1f8c443cbc439e79d9e2c8b92643b65b7332db89 (diff)
downloadlibtdevnc-21fd4d27bb248d506b37c3c43969f3db2f67c820.tar.gz
libtdevnc-21fd4d27bb248d506b37c3c43969f3db2f67c820.zip
Support systemd socket activation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9651809..0b58743 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,9 @@ if test ! -z "$with_ffmpeg"; then
fi
AM_CONDITIONAL(HAVE_MP3LAME, test "$HAVE_MP3LAME" = "true")
+PKG_CHECK_MODULES([LIBSYSTEMD], [libsystemd], [with_systemd=1], [with_systemd=0])
+AM_CONDITIONAL([WITH_SYSTEMD], [test $with_systemd -eq 1])
+
# Seem to need this dummy here to induce the 'checking for egrep... grep -E', etc.
# before it seemed to be inside the with_jpeg conditional.
AC_CHECK_HEADER(thenonexistentheader.h, HAVE_THENONEXISTENTHEADER_H="true")