summaryrefslogtreecommitdiffstats
path: root/src/tools/sdcc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/sdcc/CMakeLists.txt')
-rw-r--r--src/tools/sdcc/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/tools/sdcc/CMakeLists.txt b/src/tools/sdcc/CMakeLists.txt
new file mode 100644
index 0000000..c79c037
--- /dev/null
+++ b/src/tools/sdcc/CMakeLists.txt
@@ -0,0 +1,15 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+
+##### subfolders
+
+add_subdirectory( gui )
+
+
+##### libsdcc (static)
+
+tde_add_library( sdcc STATIC_PIC AUTOMOC
+ SOURCES sdcc_compile.cpp sdcc_config.cpp sdcc.cpp sdcc_generator.cpp
+)