summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-12-30 22:44:56 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-12-30 22:44:56 +0900
commit47af68ccb7e8550df716a5d79ffdbc51e69b8acb (patch)
tree15f025969400cc6f6ccf2e5c8a891d0036a3c98f /src/CMakeLists.txt
parent75932c4261a3f1d614fd5faeaea2227d51948e15 (diff)
downloadpolkit-agent-tde-47af68ccb7e8550df716a5d79ffdbc51e69b8acb.tar.gz
polkit-agent-tde-47af68ccb7e8550df716a5d79ffdbc51e69b8acb.zip
Added autostart desktop file.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c6d65bf..abf96b7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,7 +25,14 @@ link_directories(
)
-##### executables #########################
+##### autostart file #####
+
+configure_file( polkit-agent-tde.desktop.cmake polkit-agent-tde.desktop @ONLY )
+install( FILES ${CMAKE_CURRENT_BINARY_DIR}/polkit-agent-tde.desktop
+ DESTINATION ${AUTOSTART_INSTALL_DIR} )
+
+
+##### executables #####
tde_add_executable( polkit-agent-tde AUTOMOC
SOURCES AuthDialogWidget.ui AuthDetailsWidget.ui AuthDialog.h AuthDialog.cpp