summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-11-20 17:25:17 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-11-20 17:25:17 +0900
commit652c2aea23bd9dea082f5de2c0babe1728ac608f (patch)
tree3e649e665e3b073d2017f727fa0515f27474abd2 /CMakeLists.txt
parent1200d940add87b767246e45080e25ed207eee014 (diff)
downloadpolkit-tqt-652c2aea23bd9dea082f5de2c0babe1728ac608f.tar.gz
polkit-tqt-652c2aea23bd9dea082f5de2c0babe1728ac608f.zip
Added test framework.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba276505b..fc3526b0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ include( FindPkgConfig )
include( CheckCXXSourceCompiles )
include( CheckSymbolExists )
include( TDEMacros )
+enable_testing( )
##### optional stuff
@@ -82,6 +83,7 @@ add_definitions(
add_subdirectory(core)
add_subdirectory(gui)
add_subdirectory(agent)
+add_subdirectory(tests)
##### install files #### ########################