summaryrefslogtreecommitdiffstats
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-01-03 17:55:46 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-01-04 04:06:38 +0100
commit2971f209dbecd56266de42030d226b9085c6bf63 (patch)
treedadecfc99544e994f11c55a70e9957ae67d0e788 /gui/CMakeLists.txt
parent27ea6ede3cc480e4680fcc56b29df6ea824f7877 (diff)
downloadpolkit-tqt-2971f209dbecd56266de42030d226b9085c6bf63.tar.gz
polkit-tqt-2971f209dbecd56266de42030d226b9085c6bf63.zip
CMake rules adjustments:
+ Use the usual TDESetupPaths macros. + Install libraries according to multi-arch rules. + Use `install( DIRECTORY ... )` for headers in CXX style. + Remove linking unused variables ${..._MOCS}. + Remove linking for indirectly used libraries. + Use private linking for exported CMake targets. + Add the installation of exported CMake targets. + Use keyword TEST for tde_add_check_executable. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index 0627613a7..8a1f39695 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -30,19 +30,20 @@ install(
polkit-tqt-gui-action.h
polkit-tqt-gui-actionbutton.h
polkit-tqt-gui-actionbuttons.h
- DESTINATION ${INCLUDE_INSTALL_DIR}
+ DESTINATION ${INCLUDE_INSTALL_DIR}/${CMAKE_PROJECT_NAME}
)
##### polkit-tqt-gui (shared) #########################
tde_add_library( polkit-tqt-gui SHARED AUTOMOC
- SOURCES ${polkit_tqt_gui_MOCS}
+ SOURCES
polkit-tqt-gui-action.cpp
polkit-tqt-gui-actionbutton.cpp
polkit-tqt-gui-actionbuttons.cpp
VERSION 0.0.0
CXX_FEATURES cxx_nullptr
- LINK ${TQT_LIBRARIES} ${POLKIT_GOBJECT_LIBRARIES} polkit-tqt-core-shared
+ LINK polkit-tqt-core-shared
+ LINK_PRIVATE ${POLKIT_GOBJECT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)