summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index 0d0e22859..5f20a6130 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -32,14 +32,14 @@ install(
polkit-tqt-identity.h
polkit-tqt-subject.h
polkit-tqt-temporaryauthorization.h
- DESTINATION ${INCLUDE_INSTALL_DIR}
+ DESTINATION ${INCLUDE_INSTALL_DIR}/${CMAKE_PROJECT_NAME}
)
##### polkit-tqt-core (shared) #########################
tde_add_library( polkit-tqt-core SHARED AUTOMOC
- SOURCES ${polkit_tqt_core_MOCS}
+ SOURCES
polkit-tqt-actiondescription.cpp
polkit-tqt-authority.cpp
polkit-tqt-details.cpp
@@ -48,6 +48,7 @@ tde_add_library( polkit-tqt-core SHARED AUTOMOC
polkit-tqt-temporaryauthorization.cpp
VERSION 0.0.0
CXX_FEATURES cxx_nullptr
- LINK ${TQT_LIBRARIES} ${POLKIT_GOBJECT_LIBRARIES}
+ LINK ${TQT_LIBRARIES}
+ LINK_PRIVATE ${POLKIT_GOBJECT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)