summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 000000000..7e7c9fd1f
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,20 @@
+enable_testing()
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/agent
+)
+
+automoc4_add_executable(polkit-qt-test
+ test.cpp
+)
+
+target_link_libraries(polkit-qt-test
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTTEST_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ polkit-qt-core-1
+)
+
+add_test(BaseTest ${CMAKE_CURRENT_BINARY_DIR}/polkit-qt-test)