summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-10 20:44:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-10 20:44:18 +0000
commita39b92f278f6d1530cb151875b445185951634df (patch)
tree3adaf003614915d78c38782a51353690f9136852 /src/Makefile.am
downloadpotracegui-a39b92f278f6d1530cb151875b445185951634df.tar.gz
potracegui-a39b92f278f6d1530cb151875b445185951634df.zip
Added KDE3 version of POTraceGUI
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/potracegui@1101754 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..377314a
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,34 @@
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = potracegui.h autotraceformats.h mainwidget.h options.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/potracegui.pot
+
+KDE_ICON = potracegui
+
+#########################################################################
+# APPLICATION SECTION
+#########################################################################
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+bin_PROGRAMS = potracegui
+
+# the application source, library search path, and link libraries
+potracegui_SOURCES = main.cpp potracegui.cpp autotraceformats.cpp MainWidgetBase.ui mainwidget.cpp options.cpp
+potracegui_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+potracegui_LDADD = $(LIB_KIO) $(LIB_KDEUI)
+
+# this is where the desktop file will go
+shelldesktopdir = $(kde_appsdir)/Utilities
+shelldesktop_DATA = potracegui.desktop
+
+# this is where the shell's XML-GUI resource file goes
+shellrcdir = $(kde_datadir)/potracegui
+shellrc_DATA = potraceguiui.rc
+