summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-07-04 04:25:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-07-04 16:05:56 +0200
commitc1af0d24170f02f8c9d267258bdb7741426c9a39 (patch)
tree669aedd4856e8b9af2d36d202210122cfaf97df9 /src/CMakeLists.txt
parentbf76e158be9f0db60eb55bcb5395ebc76389dc3f (diff)
downloadsmartcardauth-c1af0d24170f02f8c9d267258bdb7741426c9a39.tar.gz
smartcardauth-c1af0d24170f02f8c9d267258bdb7741426c9a39.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..474ac2d
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,43 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### smartauthckpasswd (executable)
+
+tde_add_executable( smartauthckpasswd
+
+ SOURCES
+ ckpasswd.c
+ xmalloc.c
+ messages.c
+ LINK
+ ${CRYPT_LIBRARY}
+ ${PAM_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### smartauthmon (executable)
+
+tde_add_executable( smartauthmon
+
+ SOURCES
+ smartauthmon.cpp
+ ckpass.c
+ xmalloc.c
+ messages.c
+ LINK
+ ${CRYPT_LIBRARY}
+ ${PAM_LIBRARIES}
+ ${TQT_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)