summaryrefslogtreecommitdiffstats
path: root/plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/Makefile.am')
-rw-r--r--plugin/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugin/Makefile.am b/plugin/Makefile.am
new file mode 100644
index 0000000..db77a81
--- /dev/null
+++ b/plugin/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+kde_module_LTLIBRARIES = konqsidebar_smb4k.la
+konqsidebar_smb4k_la_SOURCES = smb4k_konqplugin.cpp
+konqsidebar_smb4k_la_LDFLAGS = -module $(all_libraries) \
+ -L$(top_builddir)/smb4k/core -L$(topbuild_dir)/smb4k/widgets -lkonqsidebarplugin
+konqsidebar_smb4k_la_LIBADD = $(top_builddir)/smb4k/core/libsmb4kcore.la \
+ $(KDE_PLUGIN) $(LIB_KFILE) $(LIB_KPARTS) $(LIB_QT) $(LIB_KDECORE) \
+ $(LIB_KDEUI)
+
+globaladddir = $(kde_datadir)/konqsidebartng/add
+globaladd_DATA = smb4k_add.desktop
+noinst_HEADERS = smb4k_konqplugin.h