summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-13 12:46:59 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-14 23:32:11 +0900
commit4af11cf947c2949ff4c7035c48f59439f1420bc8 (patch)
tree0d554bb33df8a9892982d9153c18a9e8457375e6 /CMakeLists.txt
parent10b018766921803a73a6cabdf4784b4ac7f162c9 (diff)
downloadtde-cmake-4af11cf947c2949ff4c7035c48f59439f1420bc8.tar.gz
tde-cmake-4af11cf947c2949ff4c7035c48f59439f1420bc8.zip
Set cmake minimum version in a centralized place
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit a8c01019d7aaa2e9e9165504cfdf76b05ec128dc)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 783616d..2e95052 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,13 @@ if( "${CMAKE_CURRENT_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}" )
##### general package setup #####################
- cmake_minimum_required( VERSION 3.5 )
+ # building tde-cmake requires reading the minimum required version
+ # from the source files, because there may be a different version
+ # of tde-cmake already installed in the system. Trying to build
+ # tde-cmake with a lower minimum version would not be allowed then.
+
+ include( ${CMAKE_SOURCE_DIR}/modules/TDEVersion.cmake )
+ cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
project( tde-cmake-rules )