summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..75584ae
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,33 @@
+#################################################
+#
+# (C) 2021 Slávek Banko
+# slavek.banko (at) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+## Process only if it is built as a standalone package
+if( "${CMAKE_CURRENT_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}" )
+
+##### general package setup #####################
+
+ cmake_minimum_required( VERSION 2.8.12 )
+ project( tde-cmake-rules )
+
+
+##### install TDE CMake files ###################
+
+ file( GLOB_RECURSE _modules
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/modules/* )
+ install( FILES ${_modules} DESTINATION ${CMAKE_ROOT}/Modules )
+
+ file( GLOB_RECURSE _templates
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/templates/* )
+ install( FILES ${_templates} DESTINATION ${CMAKE_ROOT}/Templates )
+
+endif()