summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-29 16:09:03 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-30 12:06:32 +0000
commit4a70fc14bfaa79ebdf590d902771b2dcea26fda7 (patch)
tree377d39e5762785a199f48eb0830dce0417cdefe4
parent8a58e579fba7cebfce3d1170aa5fd3490013e5a1 (diff)
downloadtde-packaging-gentoo-4a70fc14bfaa79ebdf590d902771b2dcea26fda7.tar.gz
tde-packaging-gentoo-4a70fc14bfaa79ebdf590d902771b2dcea26fda7.zip
Live ebuilds: Add preliminary `KBarcode` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-apps/kbarcode/kbarcode-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/kbarcode/kbarcode-9999.ebuild b/trinity-apps/kbarcode/kbarcode-9999.ebuild
new file mode 100644
index 00000000..1e9b534e
--- /dev/null
+++ b/trinity-apps/kbarcode/kbarcode-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de el es fi fr hu it nl pl sv tr"
+
+inherit trinity-base-2
+
+DESCRIPTION="Barcode and label printing application for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+# Native GNU Barcode support seems to be broken right now.
+# The GNU Barcode binary is needed anyway.
+
+IUSE+=" javascript native_gnu_barcode"
+
+RDEPEND+=" app-text/barcode
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick )"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NATIVE_GNU_BARCODE="$(usex native_gnu_barcode)"
+ -DWITH_JAVASCRIPT="$(usex javascript)"
+ )
+
+ trinity-base-2_src_configure
+}