summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-31 02:19:41 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-31 16:36:01 +0000
commit6fb5630e6709b3cb9fac8f189bca658f5489e14e (patch)
tree14c55b7fdf162ceebac0c49ba4bf3ea4f5d054f7
parent3ad534419b773150d7b483914d241bbf554fbbc5 (diff)
downloadtde-packaging-gentoo-6fb5630e6709b3cb9fac8f189bca658f5489e14e.tar.gz
tde-packaging-gentoo-6fb5630e6709b3cb9fac8f189bca658f5489e14e.zip
Live ebuilds: Add preliminary `Basket` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-apps/basket/basket-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/basket/basket-9999.ebuild b/trinity-apps/basket/basket-9999.ebuild
new file mode 100644
index 00000000..8bfc0baf
--- /dev/null
+++ b/trinity-apps/basket/basket-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="cs da de es fr it ja nl nn pl_PL pt ru sk tr zh_CN zh_TW"
+
+inherit trinity-base-2
+
+DESCRIPTION="A multi-purpose note-taking application for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+need-arts optional
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" crypt +svg kontact"
+
+DEPEND+=" crypt? ( app-crypt/gpgme )
+ svg? ( =media-libs/libart_lgpl-${PV} )
+ kontact? ( =trinity-base/kontact-${PV} )"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_KONTACT_PLUGIN="$(usex kontact)"
+ -DWITH_LIBART="$(usex svg)"
+ -DWITH_GPGME="$(usex crypt)"
+ )
+
+ trinity-base-2_src_configure
+}