summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-23 00:34:21 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-04-22 22:40:40 +0000
commit9950b6bb4f1c3abfc9b8af79850fd708aef81e58 (patch)
tree0af3314951ca83f625e0550ebebdea6ec8586ecd
parentac5ef443c43b2bb78a958e3fd4fb4b48533be47a (diff)
downloadtde-packaging-gentoo-9950b6bb4f1c3abfc9b8af79850fd708aef81e58.tar.gz
tde-packaging-gentoo-9950b6bb4f1c3abfc9b8af79850fd708aef81e58.zip
Live ebuilds: Force `xinerama` USE of Kaffeine.
Also: Fix some typo of previous commit. Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--profiles/package.use.force7
-rw-r--r--trinity-apps/kaffeine/kaffeine-9999.ebuild6
2 files changed, 9 insertions, 4 deletions
diff --git a/profiles/package.use.force b/profiles/package.use.force
index ed663958..fe4581de 100644
--- a/profiles/package.use.force
+++ b/profiles/package.use.force
@@ -1,3 +1,8 @@
# Chris (2020-04-22)
# Building without tdehwlib segfaults, but you can try and report.
-=trinity-libs/tdelibs-9999 hwlib \ No newline at end of file
+=trinity-base/tdelibs-9999 hwlib
+
+Chris (2020-04-22)
+# As of today Kaffeine can be only build with xinerama support.
+# If that is fixed, the build option will be optional again.
+trinity-apps/kaffeine xinerama \ No newline at end of file
diff --git a/trinity-apps/kaffeine/kaffeine-9999.ebuild b/trinity-apps/kaffeine/kaffeine-9999.ebuild
index 7e8cfd6b..3a04ae95 100644
--- a/trinity-apps/kaffeine/kaffeine-9999.ebuild
+++ b/trinity-apps/kaffeine/kaffeine-9999.ebuild
@@ -21,7 +21,7 @@ need-trinity
SLOT="${TRINITY_VER}"
-IUSE+=" dvb dpms gstreamer vorbis encode xcb"
+IUSE+=" dvb dpms gstreamer vorbis encode xcb xinerama"
# As of April 2020 Kaffeine can be only build with xinerama support.
# If that is fixed, the build option will be optional again.
@@ -38,7 +38,7 @@ DEPEND+="
encode? ( media-sound/lame )
vorbis? ( media-libs/libvorbis )
xcb? ( x11-libs/libxcb )
- x11-libs/libXinerama
+ xinerama? ( x11-libs/libXinerama )
dvb? ( virtual/linuxtv-dvb-headers )"
RDEPEND+=" ${DEPEND}"
@@ -47,7 +47,7 @@ src_configure() {
-DBUILD_TRANSLATIONS=ON
-DWITH_XTEST=ON
-DWITH_DPMS="$(usex dpms)"
- -DWITH_XINERAMA=ON
+ -DWITH_XINERAMA="$(usex xinerama)"
-DWITH_XCB="$(usex xcb)"
-DWITH_GSTREAMER="$(usex gstreamer)"
-DWITH_OGGVORBIS="$(usex vorbis)"