summaryrefslogtreecommitdiffstats
path: root/Documentation/scripts/update-keywords-lists
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /Documentation/scripts/update-keywords-lists
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'Documentation/scripts/update-keywords-lists')
-rwxr-xr-xDocumentation/scripts/update-keywords-lists32
1 files changed, 32 insertions, 0 deletions
diff --git a/Documentation/scripts/update-keywords-lists b/Documentation/scripts/update-keywords-lists
new file mode 100755
index 00000000..9390cdfb
--- /dev/null
+++ b/Documentation/scripts/update-keywords-lists
@@ -0,0 +1,32 @@
+#!/bin/bash
+
+DOC="Documentation"
+KEYWORDS_LIVE="$DOC/trinity.live.keywords"
+KEYWORDS_3_5_13_2="$DOC/trinity.3.5.13.2.keywords"
+
+resort() {
+ cp "${1}" "${1}.bak"
+ cat "${1}.bak" | sort -u >"$1" && rm "${1}.bak"
+}
+
+find trinity-base/ trinity-apps/ -iname '*9999.ebuild' | while read eb; do
+ PN="$(basename $(dirname ${eb}))"
+ C="$(basename $(dirname $(dirname ${eb})))"
+ P="$(basename ${eb%%.ebuild})"
+ if ! grep "^~$C/$P " "${KEYWORDS_LIVE}" >/dev/null 2>&1; then
+ echo "~$C/$P **" | tee -a "${KEYWORDS_LIVE}"
+ fi
+done
+
+resort "${KEYWORDS_LIVE}"
+
+
+find trinity-base/ trinity-apps -iname '*3.5.13.2.ebuild' | while read eb; do
+ PN="$(basename $(dirname ${eb}))"
+ C="$(basename $(dirname $(dirname ${eb})))"
+ P="$(basename ${eb%%.ebuild})"
+ if ! grep "^~$C/$P" "${KEYWORDS_3_5_13_2}" >/dev/null 2>&1; then
+ echo "~$C/$P" | tee -a "${KEYWORDS_3_5_13_2}"
+ fi
+done
+resort "${KEYWORDS_3_5_13_2}"