summaryrefslogtreecommitdiffstats
path: root/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-26 12:59:42 +0100
committerChris <xchrisx@uber.space>2020-03-26 12:59:42 +0100
commit173015ae98f2409961976f77c4350217fece06d2 (patch)
tree2ca8cc9fa67f910696de140f5d78d3d14285b8a0 /app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
parentc164cbfdd0a6a7f35dd66b5f0f2454faca4edcb0 (diff)
downloadtde-packaging-gentoo-173015ae98f2409961976f77c4350217fece06d2.tar.gz
tde-packaging-gentoo-173015ae98f2409961976f77c4350217fece06d2.zip
Add `pinentry` ebuild as TQt version.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild')
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
new file mode 100644
index 00000000..1cc024f4
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+S="${FILESDIR}"
+
+src_install() {
+ default
+ insinto /usr/share/eselect/modules
+ newins pinentry.eselect-${PV} pinentry.eselect
+}