summaryrefslogtreecommitdiffstats
path: root/dev-libs/libr
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-17 20:59:46 +0300
committerormorph <roma251078@mail.ru>2024-04-17 20:59:46 +0300
commit4b3f0a054757e31efd942db76c6f28e4c26433dd (patch)
tree742360a065f0776f4bf6bd0eae51da15d0d975a2 /dev-libs/libr
parent2769940be476aca58d96f626ecab898409ad8b48 (diff)
downloadtde-packaging-gentoo-4b3f0a054757e31efd942db76c6f28e4c26433dd.tar.gz
tde-packaging-gentoo-4b3f0a054757e31efd942db76c6f28e4c26433dd.zip
Removing version TDE-14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'dev-libs/libr')
-rw-r--r--dev-libs/libr/Manifest1
-rw-r--r--dev-libs/libr/libr-14.1.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-libs/libr/Manifest b/dev-libs/libr/Manifest
index 90dbeda5..140ef93e 100644
--- a/dev-libs/libr/Manifest
+++ b/dev-libs/libr/Manifest
@@ -1,2 +1 @@
-DIST libr-trinity-14.1.0.tar.xz 83092 BLAKE2B a7ecc1401bbacbb53794aa16d7aba1c731cf76f1988b036ff2ebae2d29fcce1b1abaf36d74e439e9518aa475888efcd409abecd06fe805e584649e3d3fc7922a SHA512 db55623c1da02d3dabb072e150a4b1299b8a82b1969296fe0bc8fbb9f18b199bb600ee2cfb087b661399bf6f2841ecd3e8b6c86003d67bd5bb7c918e1f55c3ba
DIST libr-trinity-14.1.1.tar.xz 83108 BLAKE2B 8931995598c56834aefc100578ccb251467d51047e43e9a70109176209adf3847cbf0b6e10f35e7b032c2cf4205aa788e09cb09c39168d7aabbc8f97996ce034 SHA512 81e1c1a712b3600402955a5a9d0444b408da7a14c7482b04c1d7c6c8877b66b0bd7022e30ee921d6a1e641929688a0678d10131780eed3adef78549da2fed97e
diff --git a/dev-libs/libr/libr-14.1.0.ebuild b/dev-libs/libr/libr-14.1.0.ebuild
deleted file mode 100644
index b5d8a36a..00000000
--- a/dev-libs/libr/libr-14.1.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Copyright 2020-2024 The Trinity Desktop Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-TRINITY_MODULE_TYPE="dependencies"
-TRINITY_MODULE_NAME="libr"
-inherit trinity-base-2
-
-DESCRIPTION="ELF resource access and editing library"
-HOMEPAGE="https://trinitydesktop.org/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-if [[ ${PV} != *9999* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-IUSE="+bfd elf man"
-REQUIRED_USE="?? ( bfd elf )"
-
-RDEPEND="
- sys-libs/zlib:=
- bfd? ( sys-libs/binutils-libs:= )
- elf? ( virtual/libelf:= )
-"
-DEPEND="${RDEPEND}
- x11-libs/gtk+:2
-"
-# NOTE: gtk uses weak linkage, so it's not necessary during runtime
-BDEPEND="man? ( app-text/doxygen )"
-
-pkg_setup() {
- if ! use bfd && ! use elf; then
- ewarn "You haven't selected nor \"bfd\" nor \"elf\" as a backend"
- ewarn "a fallback read-only implementation will be used to"
- ewarn "access elf resources, but modification of elf files will"
- ewarn "be unavailable."
- fi
-}
-
-src_prepare() {
- trinity-base-2_src_prepare
-
- if ! use man; then
- rm -rf man || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_BACKEND_LIBBFD=$(usex bfd)
- -DWITH_BACKEND_LIBELF=$(usex elf)
- -DWITH_BACKEND_READONLY=$( (! use bfd && ! use elf) && echo yes || echo no )
- )
-
- cmake_src_configure
-}