summaryrefslogtreecommitdiffstats
path: root/dev-python/pytde
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /dev-python/pytde
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'dev-python/pytde')
-rw-r--r--dev-python/pytde/Manifest1
-rw-r--r--dev-python/pytde/pytde-14.1.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytde/Manifest b/dev-python/pytde/Manifest
new file mode 100644
index 00000000..d4e21e0c
--- /dev/null
+++ b/dev-python/pytde/Manifest
@@ -0,0 +1 @@
+DIST pytde-trinity-14.1.0.tar.xz 973688 BLAKE2B d593d95bfa75a08fb8cd4ebbadb3d878bdbcb198c9792a3985782ff0114220de57f79710252f28634acacc6584350e58aa583c5ed71f8995dd69b91181bd1d5f SHA512 2f4cfa4fee52cbaf80d2d6b25f0a731fc0e738fca87fa93204b5d9b34174c01b6aeca18750a5055457a7df11d85029ed004dd0d3e119bc7a064248129477ab66
diff --git a/dev-python/pytde/pytde-14.1.0.ebuild b/dev-python/pytde/pytde-14.1.0.ebuild
new file mode 100644
index 00000000..be3f2c75
--- /dev/null
+++ b/dev-python/pytde/pytde-14.1.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="libraries"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit trinity-base-2 python-single-r1
+
+DESCRIPTION="Trinity bindings for Python - Development files and scripts"
+HOMEPAGE="https://trinitydesktop.org/"
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ ~dev-python/sip4-tqt-${PV}
+ ~x11-libs/tqscintilla-${PV}
+ ~dev-tqt/tqtinterface-${PV}
+ ~dev-python/pytqt-${PV}
+"
+RDEPEND="${DEPEND}"
+
+TQBASE="/usr/tqt3"
+BUILD_DIR="${S}"
+
+src_prepare() {
+ eapply_user
+}
+
+src_configure() {
+ local myconf
+ myconf=(
+ -k "${TDEDIR}"
+ -L "${TDEDIR}/$(get_libdir)"
+ -v "${TQBASE}/sip/tde"
+ )
+ "${EPYTHON}" configure.py "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ if use examples ; then
+ insinto "${TDEDIR}/share/pytde/examples"
+ doins examples/*
+ local EDIR
+ for EDIR in uimodules pytde-sampler pytde-sampler/basic_widgets pytde-sampler/dialogs pytde-sampler/icon_handling pytde-sampler/misc pytde-sampler/qt_widgets pytde-sampler/xwin
+ do
+ insinto "${TDEDIR}/share/pytde/examples/${EDIR}"
+ doins "examples/${EDIR}"/*
+ done
+ fi
+}