summaryrefslogtreecommitdiffstats
path: root/dev-python/pytde
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-17 20:59:46 +0300
committerormorph <roma251078@mail.ru>2024-04-17 20:59:46 +0300
commit4b3f0a054757e31efd942db76c6f28e4c26433dd (patch)
tree742360a065f0776f4bf6bd0eae51da15d0d975a2 /dev-python/pytde
parent2769940be476aca58d96f626ecab898409ad8b48 (diff)
downloadtde-packaging-gentoo-4b3f0a054757e31efd942db76c6f28e4c26433dd.tar.gz
tde-packaging-gentoo-4b3f0a054757e31efd942db76c6f28e4c26433dd.zip
Removing version TDE-14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'dev-python/pytde')
-rw-r--r--dev-python/pytde/Manifest1
-rw-r--r--dev-python/pytde/pytde-14.1.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pytde/Manifest b/dev-python/pytde/Manifest
index 0e16c869..9d4581af 100644
--- a/dev-python/pytde/Manifest
+++ b/dev-python/pytde/Manifest
@@ -1,2 +1 @@
-DIST pytde-trinity-14.1.0.tar.xz 973688 BLAKE2B d593d95bfa75a08fb8cd4ebbadb3d878bdbcb198c9792a3985782ff0114220de57f79710252f28634acacc6584350e58aa583c5ed71f8995dd69b91181bd1d5f SHA512 2f4cfa4fee52cbaf80d2d6b25f0a731fc0e738fca87fa93204b5d9b34174c01b6aeca18750a5055457a7df11d85029ed004dd0d3e119bc7a064248129477ab66
DIST pytde-trinity-14.1.1.tar.xz 973556 BLAKE2B a1ad356f94cdfe98104721c44fd4011c2ee86849508d59206e8de8dacb6f5255574f4e727ae1089960c96905ebba3bba6abaa831351b6330ed7c6793a491bcbe SHA512 34ee594a019c78480ecee45c2c0c2c0f4b7eb7278442cda344bc8967df9a9654dbc381ab9effe0036ad758e8455dc2cc4edd04600d3690da8559e80415551fd6
diff --git a/dev-python/pytde/pytde-14.1.0.ebuild b/dev-python/pytde/pytde-14.1.0.ebuild
deleted file mode 100644
index b847b7d8..00000000
--- a/dev-python/pytde/pytde-14.1.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2023 The Trinity Desktop Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-TRINITY_MODULE_TYPE="libraries"
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit trinity-base-2 python-single-r1
-
-DESCRIPTION="Trinity bindings for Python - Development files and scripts"
-HOMEPAGE="https://trinitydesktop.org/"
-LICENSE="GPL-2"
-SLOT="0"
-if [[ ${PV} != *9999* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-IUSE="examples"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- ~trinity-base/tdelibs-${PV}
- ~dev-python/sip4-tqt-${PV}
- ~x11-libs/tqscintilla-${PV}
- ~dev-tqt/tqtinterface-${PV}
- ~dev-python/pytqt-${PV}
-"
-RDEPEND="${DEPEND}"
-
-TQBASE="/usr/tqt3"
-TDEDIR="/usr/trinity/14"
-BUILD_DIR="${S}"
-
-src_prepare() {
- eapply_user
-}
-
-src_configure() {
- local myconf
- myconf=(
- -k "${TDEDIR}"
- -L "${TDEDIR}/$(get_libdir)"
- -v "${TQBASE}/sip/tde"
- )
- "${EPYTHON}" configure.py "${myconf[@]}" || die
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- if use examples ; then
- insinto "${TDEDIR}/share/pytde/examples"
- doins examples/*
- local EDIR
- for EDIR in uimodules pytde-sampler pytde-sampler/basic_widgets pytde-sampler/dialogs \
- pytde-sampler/icon_handling pytde-sampler/misc pytde-sampler/qt_widgets pytde-sampler/xwin
- do
- insinto "${TDEDIR}/share/pytde/examples/${EDIR}"
- doins "examples/${EDIR}"/*
- done
- fi
-}