summaryrefslogtreecommitdiffstats
path: root/eclass/trinity-functions-2.eclass
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-09-14 22:38:46 +0200
committerormorph <roma251078@mail.ru>2022-09-14 22:45:56 +0200
commit802f52c9d328df0a1d9a86b99deedddce868ad84 (patch)
tree2bbd7afeb10103b8b90ad79b8deb56e279e14870 /eclass/trinity-functions-2.eclass
parentdf0ae35e2cbed9ff04fadf14ce4b5574440c1607 (diff)
downloadtde-packaging-gentoo-802f52c9d328df0a1d9a86b99deedddce868ad84.tar.gz
tde-packaging-gentoo-802f52c9d328df0a1d9a86b99deedddce868ad84.zip
Fixed obsolete macro definitions, added documentation for classes, functions and variables
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'eclass/trinity-functions-2.eclass')
-rw-r--r--eclass/trinity-functions-2.eclass27
1 files changed, 26 insertions, 1 deletions
diff --git a/eclass/trinity-functions-2.eclass b/eclass/trinity-functions-2.eclass
index d3b65fa0..aaae5be2 100644
--- a/eclass/trinity-functions-2.eclass
+++ b/eclass/trinity-functions-2.eclass
@@ -2,7 +2,11 @@
# Copyright 2020-2022 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
-#
+# @ECLASS: trinity-functions-2.eclass
+# @MAINTAINER:
+# gentoo@trinitydesktop.org
+# @BLURB: common ebuild functions
+# @DESCRIPTION:
# Original Author: Alexander Golubev (Fat-Zer)
# Ported to git-r3 eclass and EAPI7 by E. Liddell
# Ported to cmake eclass and EAPI8 by ormorh
@@ -11,6 +15,9 @@
inherit multilib
+# @ECLASS_VARIABLE: TRINITY_LIVEVER
+# @DESCRIPTION:
+# Sets the version of the live assembly
TRINITY_LIVEVER="14.1.0"
# @FUNCTION: set-trinityver
@@ -92,6 +99,9 @@ adjust-trinity-paths() {
unset TDEROOTHOME
}
+# @FUNCTION: trinity_remove_path_component
+# @DESCRIPTION:
+# Removes the specified path from the PATH variable.
trinity_remove_path_component() {
local i new_path path_array
@@ -107,6 +117,9 @@ trinity_remove_path_component() {
echo "${new_path#:}"
}
+# @FUNCTION: trinity_prepand_path_component
+# @DESCRIPTION:
+# Prepares a list to be added to the PATH variable.
trinity_prepand_path_component() {
local new_path
@@ -176,6 +189,9 @@ need-arts() {
RDEPEND+=" ${my_depend}";
}
+# @FUNCTION: trinity_l10n_for_each_locale_do
+# @DESCRIPTION:
+# This function is required to build the locale.
trinity_l10n_for_each_locale_do() {
local locs x
@@ -191,6 +207,9 @@ trinity_l10n_for_each_locale_do() {
done
}
+# @FUNCTION: trinity-admin-prepare
+# @DESCRIPTION:
+# This function prepares the source for building.
trinity-admin-prepare() {
pushd "${PWD}/admin"
libtoolize -c || die "Error libtoolize"
@@ -199,11 +218,17 @@ trinity-admin-prepare() {
popd
}
+# @FUNCTION: trinity-gen-configure
+# @DESCRIPTION:
+# This function generates a configure script to build.
trinity-gen-configure() {
trinity-admin-prepare
emake -f admin/Makefile.common || die "Error creating configuration"
}
+# @FUNCTION: trinity-econf
+# @DESCRIPTION:
+# This function configures the assembly.
trinity-econf() {
local myconf
myconf=(--prefix="${TDEDIR}"